Interruption on the on-call telephone number
Incident Report for Litium AB
Resolved
Issue have been solved!
Posted Dec 30, 2023 - 16:41 CET
Identified
We are currently investigating this issue.
If you need to contact our on-call team, use our email address support@litium.com
Posted Dec 30, 2023 - 13:31 CET
This incident affected: Support (Support Phone).