Support phone is unreachable

Incident Report for Litium AB

Resolved

Support phones are now working.
Posted Jan 23, 2023 - 21:18 CET

Identified

Phone network operator Telia has technical issues and wide outages. Currently it is difficult to call the Litium support number.
Email is working normally.
Posted Jan 23, 2023 - 12:00 CET
This incident affected: Support (Support Phone).