Support phones out order.
Incident Report for Litium AB
Resolved
Phones are now operational.
Posted Sep 15, 2024 - 11:17 CEST
Investigating
Support phones for SLA customers are currently unreachable. All urgent issues must be reported by email until further notice.
Please use support@litium.com
Posted Sep 15, 2024 - 10:01 CEST
This incident affected: Support (Support Phone).