Support phone down.
Incident Report for Litium AB
Resolved
Support phone lines are now operational.
Posted Sep 23, 2023 - 21:08 CEST
Identified
Support phone lines are currently down. All urgent support cases must be sent by email to support@litium.com

Current assessment is that phones are be back 22.00.
Posted Sep 23, 2023 - 16:24 CEST
This incident affected: Support (Support Phone).