Support email down
Incident Report for Litium AB
Resolved
Support emails are now working.
Posted Nov 26, 2024 - 06:34 CET
Investigating
All incoming emails are delayed due to outage in external mail traffic.
For urgent cases please use the support phone : 036-210 33 30
Posted Nov 25, 2024 - 12:06 CET
This incident affected: Support (Support Email).